关闭
当前位置:首页 - 中超联赛 - 正文

番荔枝,干货共享:H3C交换机的装备指令及VLAN装备事例-英伦芬芳,优雅绽放,时尚经典故事,巴黎往事

admin 2019-07-12 162°c

一、H3C交换机的根本配备

咱们先来了解下h3c的配备指令与功用,都是常用的,根本上大部分网络配备都少不了这些指令。

1、根本配备

//用户直行形式提示符,用户视图

system-view //进入配备视图

[H3C] sysname番荔枝,干货同享:H3C交换机的配备指令及VLAN配备案例-英伦芳香,高雅开放,时髦经典故事,巴黎往事 xxx //设置主机名成为xxx这儿运用修正特权用户暗码

2、用户配备

system-view

[H3C]super passwordH3C //设置用户分级暗码

[H3C]undo superpassword //删去用户分级暗码

[H3C]localuser bigheap 1234561 //Web网管用户设置,1(缺省)为办理级用户,缺省admin,admin

[H3C]undo localuserbigheap //删去Web网管用户

[H3C]user-interface aux0 //只支撑0

[H3C-Aux]idle-timeout 2腾达路由器50 //设置超时为2分50秒,若为0则表明不超时,默以为5分钟

[H3C-Aux]undoidle-timeout //康复默许值

[H3C]user-interface vty0 //只支撑0和1

[H3C-vty]idle-timeout 250 //设置超时为2分50秒,若为0则表明不超时,默以为5分钟

[H3C-vty]undoidle-timeout //康复默许值

[H3C-vty]set authentication password123456 //设置telnet暗码,有必要设置

[H3C-vty]undo set authenticationpassword //撤销暗码

[H3C]displayusers //显现用户

[H3C]displayuser-interface //用户界面情况

3、VLAN配备

[H3C]vlan 2 //创立VLAN2

[H3C]undo vlanall //删去除缺镇远古镇省VLAN外的一切VLAN,缺省VLAN不能被删去

[H3C-vlan2]port Ethernet 0/4 to Ethernet0/7 //将4到7号端口参加到VLAN2中,此指令只能用来加access端口,不能用来增加trunk或许hybrid端口

[H3C-burningvlan2]port-isolateenable //翻开VLAN内端口阻隔特性,不能二层转发,默许不启用该功用

[H3C-Etherne辽宁电视台t0/4]port-isolate uplink-portvlan 2 //设置4为VLAN2的阻隔上行端口,用于转发二层数据,只能配备一个上行端口,若为trunk,则主张答应一切VLAN经过,阻隔不能与会聚一起配备

[H3C]display vlanall //显现一切VLAN的详细信息

S1550E支撑依据端口的VLAN,经过创立不同的user-group来完成,一个端口能够归于多个user-group,不归于同一个user-group的端口不能相互通讯

[H3C]user-group20 //创立user-group 20,默许只存在user-group 1

[H3C-UserGroup20]port Ethernet 0/4 toEthernet 0/7 //将4到7号端口参加到VLAN20中,初始时都归于user-group 1中

[H3C]display user-group20 //显现user-group 20的相关信息

4、交换机IP配备

[H3C]vlan 20 //创立vlan

[H3C]management-vlan 20 //办理vlan

[H3C]interface vlan-interface20 //进入并办理vlan20

[H3C]undo格格 interface vlan-interface20 //删去办理VLAN接口

[H3C-Vlan-interface20]ip address192.168.1.2 255.255.255.0 //配备办理VLAN接口静态IP地址(缺省为192.168.0.234)

[H3C-Vlan-interface20]undo ipaddress //删去IP地址

[H3C-Vlan-interface20]ip gateway192.168.1.1 //指定缺省网关(默许无网关地址)

[H3C-Vlan-interface20]undo ip gateway

[H3C-Vlan-interface20]shutdown //封闭接口

[H3C-Vlan-interface20]undoshutdown //敞开

[H3C]display ip //显现办理VLAN接口IP的相关信息

[H3C]display interface vlan-interface20 //检查办理VLAN的接口信息

debuggingip //敞开IP调试功用

undo debugging ip

5、DHCP客户端配备

[H3C-Vlan-interface20]ip add番荔枝,干货同享:H3C交换机的配备指令及VLAN配备案例-英伦芳香,高雅开放,时髦经典故事,巴黎往事ressdhcp-alloc // 办理VLAN接口经过DHCP方法获取IP地址

[H3C-Vlan-interface20]undo ip addressdhcp-alloc // 撤销

[H3C]display dhcp //显现DHCP客户信息

debuggingdhcp-alloc //敞开DHCP调试功用

undo debugging dhcp-alloc

6、端口配备

[H3C]interface Ethernet0/3 //进入端口

[H3C-Ethernet0/3]shutdown //封闭端口

[H3C-Ethernet0/3]speed100 //速率可为10,100,1000和auto(缺省)

[H3C-Ethernet0/3]duplexfull //双工,可为half,full和auto(缺省) 光口和会聚后不能配备

[H3C-Ethernet0/3]flow-control //敞开流控,默以为封闭

[H3C-Ethernet0/3]broadcast-suppression20 //设置按捺播送百分比为20%,可取5,10,20,100,缺省为100,一起组播和不知道单播也受此影响

[H3C-Ethernet0/3]loopbackinternal 电锯惊魂8/番荔枝,干货同享:H3C交换机的配备指令及VLAN配备案例-英伦芳香,高雅开放,时髦经典故事,巴黎往事/内环测验

[H3C-Ethernet0/3]loopbackexternal //外环测验,需插接自环头,有必要为全双工或许自洽谈形式

[H3C-Ethernet0/3]port link-typetrunk //设置链路的类型为trunk,可为access(缺省),trunk

[H3C-Ethernet0/3]port trunk pvid vlan20 //设置20为该trunk的缺省VLAN,默以为1(trunk线路两头的PVID有必要共同)

[H3C-Ethernet0/3]port access vlan20 //将当时access端口参加指定的VLAN

[H3C-Ethernet0/3]port trunk permit vlanall //答应一切的VLAN经过当时的trunk端口,可屡次运用该指令

[H3C-Ethernet0/3]mdiauto //设置以太端口为主动监测,normal(缺省)为直通线,across为穿插线

[H3C]link-aggregation Ethernet 0/1 toEthernet 0/4 //将1-4口参加会聚组,1为主端口,两头需求一起配备,设置了端口镜像以及端口阻隔的端口无法会聚

[H3C]undo link-aggregation Ethernet0/1 //删去该会聚组

[H3C]link-aggregation modeegress //配备端口会聚形式为依据意图MAC地址进行负荷分管,可选为 ingress,egress和both,缺省为both

[H3C]monitor-port Ethernet0/2 //将该端口设置为镜像端口,有必要先设置镜像端口,删去时有必要先删去被镜像端口,并且它们不能同在一个端口,该端口不能在会聚组中,设置新镜像端口时,新替代旧,被镜像不变

[H3C]mirroring-port Ethernet 0/3 toEthernet 0/4 both //将端口3和4设置为被镜像端口,both为一起监控接纳和发送的报文,inbound表明仅监控接纳的报文,outbound表明仅监控发送的报文

[H3C]display mirror

[H3C]display interface Etherne番荔枝,干货同享:H3C交换机的配备指令及VLAN配备案例-英伦芳香,高雅开放,时髦经典故事,巴黎往事t 0/3

resetcounters //铲除一切端口的计算信息

[H3C]display link-aggregation Ethernet0/3 //显现端口会聚信息

[H3C-Ethernet0/3]virtual-cable-test //确诊该端口的电路情况

7、集群配备

S2100只能作为成员交换机参加集群中,参加后体系名改为"集群名_成员编号.原体系名"的格局.

即插即用功用经过两个功用完成: 集群办理协议MAC组播地址洽谈和办理VLAN洽谈

[H3C]cluster enable //启用群集功用,缺省为启用

[H3C]cluster //进入群集视图

[H3C-cluster]administrator-address H-H-Hname switch H-H-H为指令交换机的MAC,参加switch集群

[switch_1.H3C-cluster]undoadministrator-address //退出集群

[H3C]displaycluster //显现集群信息

[H3C]management-vlan2 //集群报文只能在办理VLAN中转发,同一集群需在同一个办理VLAN中,需在树立集群之前指定办理VLAN

8、QOS优先级配备

QoS配备过程:设置端口的优先级,设置交换机信赖报文的优先级方法,行列调度,端口限速

[H3C-Ethernet0/3]priority7 //设置端口优先级为7,默以为0

[H3C]priority-trustcos //设置交换机信赖报文的优先级方法为cos(802.1p优先级,缺省值),还能够设为dscp方法(dscp优先级方法)

[H3C]queue-scheduler hq-wrr 2 4 68 //设置行列调度算法为HQ-WRR(默以为WRR),权重为2,4,6,8

[H3C-Ethernet0/3]line-rate inbound29 //将端口进口速率限制为2Mbps,取1-28时,速率为rate*8*1024/125,即64,128,192...1.792M;29-127时,速率为(rate-27)*1024,即2M,3M,4M...100M,千兆时可持续往下取,128-240时,速率为(rate-115)*8*1024,即104M,112M,120M...1000M

[H3C]displayqueue-scheduler //显现行列调度形式及参数

[H3C]displaypriority-trust //显现优先级信赖形式

[H3C]mac-address blackhole H-H-H vlan1 //在VLAN1中增加黑洞MAC

[H3C]mac-address static H-H-H interfaceEthernetcheer 0/1 vlan 1 //在VLAN1中增加端口一的一个mac

[H3C]mac-address timer aging500 //设置MAC地址表的老化时刻为500s

[H3C]display mac-address

[H3C]display arp

[H3C]mac-address port-binding H-H-Hinterface Etherchouchanet 0/1 vlan 1 配备端口邦定

[H3C]display mac-address port-binding

[H3C]display saved-configuration

[H3C]display current-configuration

sav番荔枝,干货同享:H3C交换机的配备指令及VLAN配备案例-英伦芳香,高雅开放,时髦经典故事,巴黎往事e

[H3C]restoredefault //康复交换机出厂默许配备,康复后需重启才干收效

[H3C]display version

reboot

[H3C]display device

[H3C]sysname bigheap

[H3C]info-centerenable //启用体系日志功用,缺省情况下启用

[H3C]info-center loghost ip192.168.0.3 //向指定日志主机(只能为UNIX或LINUX,不能为Windows)输出信息,需先敞开日志功用,缺省封闭

[H3C]info-center loghost level8 //设置体系日志等级为8,默以为5.等级阐明:1.emergencies 2.alerts 3.critical4.errors 5.warnings 6.notifications 7.informational 8.debugging

terminaldebugging //启用控制台对调试信息的显现,缺省控制台为禁用

terminallogging //启用控制台对日志信息的显现,缺省控制台为启用

terminaltrapping //启用控制台对告警信息的显现,缺省控制台为启用

[H3C]displayinfo-center //显现体系日志的配备和缓冲区记载的信息

[H3C]displaylogbuffer //显现日志缓冲区最近记载的指定数意图日志信息

[H3C]displaytrapbuffer //显现告警缓冲区最近记载的指定数意图日志信息

resetlogbuffer //铲除日志缓冲区的信息

resettrapbuffer //铲除告警缓冲区的信息

二、H3C交换机VLAN配备案例

为了防止播送报文众多和通讯的安全性,某公司网络中运用VLAN技能来阻隔部分间的二层流量。其间部分A运用VLAN 100,部分B运用VLAN 200。

部分A的终端用户运用192.168.1.0/24 IP网段,各终端用户配备的网关地址为192.168.1.1;

部分B的终端用户运用192.168.2.0/24 IP网段,各终端用户配备的网关地址为192.168.2.1;

现要求经过配备依据端口的VLAN和VLAN接口完成下面使用需求:

1 同一VLAN内的主机能够二层互通,不同VLAN内的主机不能二层互通,能够三层互通。

2、经过配备使Device A作为部分A中用户的网关,Device B作为部分B中用户的网关。

组网拓扑图如下:

1、配备Device A

# 创立VLAN 100,并将GigabitEthernet 1/0/1参加VLAN 100。

system-view

[DeviceA] vlan 100

[DeviceA-vlan100] port gigabitethernet 1/0/1

[DeviceA-vlan100] quit

# 创立Vlan-interface 100,并配备其IP地址为192.168.1.1/24。

[DeviceA] interface Vlan-interface 100

[DeviceA-Vlan-interface100] ip address 192.168.1.1 24

[DeviceA-Vlan-interface100] quit

# 创立VLAN 200,并将GigabitEthernet 1/0/2参加VLAN 200。

[DeviceA] vlan 200

[DeviceA-vlan200] port gigabitethernet 1/0/2

[DeviceA义不容辞-vlan200] quit

# 创立盆栽Vlan-interface 200,并配备其IP地址为192.168.2.2/24。

[DeviceA] interface Vlan-interface 200

[DeviceA-Vlan-interface200] ip address 192.168.2.2 24

[DeviceA-Vlan-interface200] quit

# 为了使Device A上VLAN 100和VLAN 200的报文能发送给Device B,将GigabitEthernet 1/0/3的链路类型配备为Trunk,并答应VLAN 100和VLAN 200的报文经过,撤销答应VLAN 1经过。

[DeviceA] interface gigabitethernet 1/0/3

[DeviceA-GigabitEthernet1杨梅/0/3] port link-type trunk

[DeviceA-GigabitEthernet1/0/3] port trunk permit vlan 100 200

[DeviceA-GigabitEthernet1/0/3] 黄龙600undo port trunk permit vlan 1

[DeviceA-GigabitEthernet1/0/3] quit

2、配备Device B

# 创立VLAN 100,并将GigabitEthernet 1/0/1参加VLAN 100。

system-view

[DeviceB] vlan 100

[DeviceB-vlan100] port gigabitethernet 1/0/1

[DeviceB-vlan100] quit

# 创立Vlan-interface 100,并配备其IP地址为192.168.1.2/24。

[DeviceB] interface Vlan-interface 100

[DeviceB-Vlan-interface100] ip address 192.168.1.2 24

[DeviceB-Vlan-interface100] quit

# 创立VLAN 200,并将GigabitEthernet 1/0/2参加VLAN 200。

[DeviceB] vlan 200

[DevidearceB-vlan200]port gigabitethernet 1/0/2

[DeviceB-vlan200] quit

# 创立Vlan-interface 200,并配备其IP地址为192.168.2.1/24。

[DeviceB] interface Vlan-interface 200

[DeviceB-Vlan-interface200] ip address 192.168.2.1 24

[DeviceB-Vlan-interface200] quit

# 为了使Device A上VLAN 嗨文100和VLAN 200的报文能发送给Device B,将GigabitEthe颈椎牵引rnet 1/0/3的链路类型配备为Trunk,并答应VLAN 100和VLAN 200的报文经过,撤销答应VLAN 1经过。

[DeviceB] interface gigabitethernet 1/0/3

[DeviceB-GigabitEthernet1/0/3] port link-type trunk

[DeviceB-GigabitEthernet1/0/3] port trunk permit vlan 100 200

[DeviceB-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[DeviceB-GigabitEthernet1/0/3] quit

3、验证配备

(1)经过display vlan指令检查显现信息验证配备是否成功,以检查Device A上VLAN 100和VLAN 200的配备信息为例。

[DeviceA] display vlan 100

VLAN ID: 100

VLAN Type: static

Route Interface: configured

IP Address: 192.168.1.1

Subnet Mask: 255.255.255.0

Deion: VLAN 0100

Name: VLAN 0100

Tagged Ports:

GigabitEthernet1/0/3

Untagged Ports:

GigabitEthernet1/0/1

[Dev美观的道德iceA] display vlan 20中国证监会0

VLAN ID: 200

VLAN Type: static

Route Interface: configured

IP Address: 192.168.2.2

Subnet Mask: 255.255.255.0

Deion: VLAN 0200

Name: VLAN 番荔枝,干货同享:H3C交换机的配备指令及VLAN配备案例-英伦芳香,高雅开放,时髦经典故事,巴黎往事0200

Tagged Ports:

GigabitEthernet1/0/3

Untagged Ports:

Gigabi长智齿牙龈胀痛怎么办tEthernet1/0/2

(2)Host A和Host C能够相互ping通。检查Host A的ARP表,表中有Host C的IP地址和MAC地址对应的ARP表项。检查Host C的ARP表,表中有Host A的IP地址和MAC地址对应的ARP表项。

(3)Host A和Host D能够相互ping通。检查Host A的ARP表,表中没有Host D的ARP表项。检查Host D的ARP表,表中也没有Host A的ARP表项。

这儿面弥补下:

关于一些姓名,我们能够了解下它的含义。

1、静态IP:ISP供给给您固定的IP地址、子网掩码、默许网关、DNS。

2、动态IP:电脑的TCP/IP特点设置为“主动获取IP地址”,每次发动电脑即可。

3、WEB认证:每次上网之前,翻开IE浏览器,会主动跳到ISP指定的主页,填入ISP供给的用户名暗码,经过认证今后才干够进行深圳好玩的当地其他得上网操作。

4、DHCP功用:敞开后,能够主动分配IP,主要是用来给网络客户机分配动态的IP地址,不需求手动设置ip,一般路由器和三层交换机有DHCP功用番荔枝,干货同享:H3C交换机的配备指令及VLAN配备案例-英伦芳香,高雅开放,时髦经典故事,巴黎往事,二层交换机不能供给DHCP服务,但能够供给dhcp署理/中继功用。

标签: 未定义标签
admin 14文章 0评论 主页

  用户登录